Search

Supported Internet Browsers - EBSCOhost

Wed. Jun. 8, 2016

Beginning in July 2017, EBSCOhost will no longer support Internet Explorer 8.0 or 9.0 due to security risks.To avoid any service interruptions, please make all recommended browser updates before July 2017. For more information please read the complete Browser Support Policy on the EBSCO Support Site, and Minimum Browser Requirements for EBSCO Interfaces.